Jump to content
Broni

Adobe Flash crashing Firefox solution

Recommended Posts

Broni   

This issue has been haunting me for couple of months already.

Whenever I go to any site which uses Adobe Flash, Flash will crash immediately.

Firefox itself will still work but any feature supported by Flash on that given page will NOT.

I even uninstalled Firefox completely, installed pristine, fresh copy and same crashes happen.

Finally today I was able to find solution.

Apparently it's all about Adobe Flash protected mode, which seems to be incompatible with 64-bit systems.

IMPORTANT! Disabling "protected mode" through Firefox doesn't work.

You can go Tools\Add-ons\Plugins\Shockwave Flash\Options, disable "protected mode" there, restart Firefox and it doesn't help.

What works is this...

Open File Manager (Windows Explorer), navigate to:

C:\Windows\SysWOW64\Macromed\Flash

You'll see mms.cfg file there.

Open it with any text editor like Notepad.

It looks like this:

SilentAutoUpdateEnable=0
AutoUpdateDisable=0
AnalyticsUserChoice=0
AnalyticsThrottleValue=0
DisableAnalytics=0
 

Add the following line:

ProtectedMode = 0

It's case sensitive, so make sure it looks exactly like I wrote it.

Save the file, restart Firefox and you should be good to go. No more Flash crashes.

Note. Windows may not let you save the above file.

In that case "take ownership" of mms.cfg file (http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/)

Recheck the above file after next Adobe Flash update because it may delete added line.

Share this post


Link to post
Share on other sites
Shay   

Interesting, Thanks for posting your fix.

Share this post


Link to post
Share on other sites
PeggyB   

Thanks, I need this, but have no local disk c to save it to. I really hate this windows 10.

Share this post


Link to post
Share on other sites
Shay   
47 minutes ago, PeggyB said:

Thanks, I need this, but have no local disk c to save it to. I really hate this windows 10.

Click the up arrow in front of the address bar.

 

7773d1414815439-pc-shortcut-create-windo

Now browse C:\ to the address Broni posted .

Share this post


Link to post
Share on other sites
Shay   

Broni did you try these?

Advanced:
General: Uncheck Use hardware acceleration when available

about:config - dom.ipc.plugins.enabled to set value FALSE

Share this post


Link to post
Share on other sites
Broni   

@ Shay...

Yes. It didn't help.

Believe me, I tried probably every single trick posted online. No dice.

Share this post


Link to post
Share on other sites
Shay   

Well, having stuck with 32 bit and was right curious.

Thanks.

Share this post


Link to post
Share on other sites
JohnT   

Facebook seems to be most of the problem, but videos in Firefox and slimboat do not work except Utube. I tried the fix did not work.

Share this post


Link to post
Share on other sites
JohnT   

Yes I did that in the beginning, did a uninstall and reinstalled than tried the fix.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×